OS2.org Site Index - Feedback - Impressum
Sprachauswahl / Choose your Language News Software Hardware Projects Forum Tips Links Variety
Editorial Survey Discussion HelpDesk
search in for (Extended search)
( Archive ) ( New Topic )

( Show the thread view ) ( Goto Startview )
Two small annoyances (from Stonefieldt, 11:49:54) ^
I have only hours ago installed OS/2 Warp 4 on my IBM Thinkpad 380 ED, and am 98% satisfied with it as it is fast and takes up so little space on the hard drive. Unfortunately, there are two small annoyances that make this otherwise wonderful OS enjoyable.

First, when I start the computer, it does not go directly to OS/2, but displays text saying: "OS/2 Warp Infrared Device Driver Version 1.07.47 not installed. SYS1201: The device driver C:\OS2\BOOT\IRDD.SYS specified in the DEVICE statement on line 60 of the CONFIG.SYS file was not installed. Line 60 is ignored." It also says the same thing for "Sound BlasterPro Device Driver Version 2.25" in Line 81, as well as two others. All this really does is require me to press ENTER a few times, but it would be nice to just start the system. Information on how to fix this would be preferred, but for the moment, I would be happy with learning how I can make the system ignore the problems and get on to loading the OS.

The second annoyance is the screen resolution is 640x480, so it leaves about two centimeters of the screen blank on the sides. When I go to "system setup" and "system - properties" it says that 640x480 is the only option. On all other OS's I have used with this computer, the screen was completely filled when resolution was 800x600.

I am using OS/2 on a hobby computer so it is not really urgent that these problems get fixed soon. Any help, whether it comes sooner or later will be greatly appreciated. If any details about the intallation or the computer itself are needed, I will gladly provide them.
[ readers: 101 ]

Re: Two small annoyances (from Hans v. Mangoldt, 16:42:42)
Hello Stonefield,

ther will probably be no problam at all to run OS/2 or eCS (modern OS/2 from Serenity Systems) on your Thinkpad 380 ED.
Go to IBM on this Web-page http://www-307.ibm.com/pc/support/site.wss/product.do?template=/product.do?template=%2Fproductpage%2Flandingpages%2FproductPageLandingPage.vm&sitestyle=lenovo&brandind=10&familyind=50071&machineind=0&modelind=0&partnumberind=0&subcategoryind=0&doctypeind=9&doccategoryind=0&operatingsystemind=50685&validate=true and download the needed drivers. As standard OS/2 4.0 always came up with a resolution of 640x480x16. Only with the right display drivers you will have the best possible resolution. The driver remarks are coming up because you seem to have installed OS/2 with IRDA and sound driver. You can easily "REM" them out in "config.sys".

Good Luck and have much fun

Hans v. Mangoldt.

Re: Two small annoyances (from Ingo, 20:04:46)
Hi Stonefield,

> make the system ignore the problems

is quite easy. Just edit config.sys and put REM in front of the lines where the system complains about loading a driver. Example:


Next step is to update your drivers, which may take a while till you got them all:-)

A hint to ease that is probably to install 'os2mt' which can be found here:


Best regards,

Re: Two small annoyances (from stonefieldt, 11:49:11)
Many thanks for your help! Placing "REM" in front of the offending lines in CONFIG.SYS helped and now my system starts normally.

However, there is still the problem of the video drivers. I downloaded the files from the IBM site, and followed the procedures for creating the driver, but when I run "SETUP" in the command prompt it says that the program requires Microsoft Windows. This is very strange, as I checked the download site and some of the files multiple times and am certain that these files are intended for OS/2. I even tried Neomagic drivers from the site hobbes.nmsu.edu and got the same message. While exploring the system, I discovered something called "Selective Install", which took the computer to a screen similar to the one used when initially setting up the system. Although it did recognise that the floppy disk had the necessary driver, Selective Install displayed an error message saying that it could not install the drivers. Is there perhaps a way to work around this?

Once again, thanks for your help!

Re: Two small annoyances (from Ingo, 19:45:07)
> However, there is still the problem of the video drivers

I don't know whether it is possible to use IBM's 'special edition' of the SNAP-video driver on your system. I do not have any experience with that one on a plain Warp4 (without any fixpaks)?
(only started to use it a few months ago)

SNAP is a package distributed quite frequently on testcase and is about 10 MB in size (not every e-mail provider allows such large attachments:-) but it supports all kind of video-chips exept the most recent ones.

Perhaps somebody else can report whether SNAP will do the job.

Best regards,

Re: Two small annoyances (11:15:10)

I have the driver on my computer now and everything works perfectly! It is not the SNAP driver that you suggested, but the same vendor of that driver allows a person who creates a log-in to download a custom driver for the specific operating system and graphic card (including OS/2 with Neomagic 128), which takes up less storage space than the SNAP driver. In addition, it requires that the computer have fixpack 5 or higher.

Thanks to everyone for your help!

( Show the thread view ) [ Version for printing ] ( Goto Startview )

date topic
06/01/2017 *


Name: * eMail: notify

All * marked fields have to be filled !

php.net OpenIT" © 1998-2017 by WebTeam OS2.org